CentOS 5에서 PHP 버전을 5.1에서 5.3으로 업그레이드 하기

이번에 워드프레스가 3.2.1 버전으로 업데이트 되면서 PHP 5.2.4 이상의 버전을 요구하게 되었다.

기본 패키지에는 PHP 5.1 버전이 들어 있으므로 PHP 5.3 으로 업그레이드를 위해서는 다음과 같은 과정을 거치면 된다.

  1. Repository를 갱신한다.
# wget http://download.fedora.redhat.com/pub/epel/5/i386/epel-realease-5-4.noarch.rpm
# wget http://rpms.famillecollet.com/enterprise/remi-release-5.rpm
# rpm -Uvh remi-release-5*.rpm epel-release-5*.rpm
  1. 이전 버전의 PHP를 제거한다
# yum erase php php-pear php-mysql php-cli php-common
  1. 신규 버전의 PHP를 설치한다
# yum –enablerepo=remi install php53 php-pear php53-mysql
  1. 아파치 서버를 재가동 한다
# service httpd restart

이렇게 하게되면 PHP 버전을 업데이트 할 수 있게 된다.

참고

zemna

Programmer/Web/Mobile/Desktop

You may also like...

Leave a Reply